Switch Setup

From DISI
Jump to: navigation, search

Physically accessing the switch

I am running Ubuntu 14.04 on a laptop that has USB ports. I also have putty SSH client installed. Most of our switches are old and still use the Serial port connection for direct access. We can still use that but we need a USB to female Serial port cable. I plugged a USB-to-Serial cable to my laptop and check the last entries in dmesg:

polkaron@Ubentu:~$ dmesg | tail
[79465.042532] usb 2-1.1: new full-speed USB device number 5 using ehci-pci
[79465.135955] usb 2-1.1: New USB device found, idVendor=067b, idProduct=2303
[79465.135964] usb 2-1.1: New USB device strings: Mfr=1, Product=2, SerialNumber=0
[79465.135970] usb 2-1.1: Product: USB-Serial Controller D
[79465.135974] usb 2-1.1: Manufacturer: Prolific Technology Inc. 
[79465.136479] pl2303 2-1.1:1.0: pl2303 converter detected
[79465.138104] usb 2-1.1: pl2303 converter now attached to ttyUSB0

Note the above output. The most important entry is the last line that mentions "ttyUSB0"

You must open Putty SSH Client as root. Upon opening Putty, I scroll all the way down to the Serial submenu. There is a line called "Serial Line to connect to" In this space is where I want to write in the name that dmesg showed when I plugged in my USB-Serial connection so I'll write "ttyUSB0" into the space (which is probably prepopulated with some other weird entry).

Afterwards on Putty, I'll scroll back to the top of the menu and click "Session". On "Connection Type", I want to select "Serial" and on the Serial Line, I want to enter the same dmesg title for the connection "ttyUSB0"

Running configuration of powerconnect 6248 switch

console#show running-config 
!Current Configuration:
!System Description "PowerConnect 6248, 3.3.3.3, VxWorks 6.5"
!System Software Version 3.3.3.3
!Cut-through mode is configured as disabled
!
configure
vlan database
vlan 100-101
vlan routing 101 1
vlan routing 100 2
vlan association subnet 10.10.0.0 255.255.0.0 100
vlan association subnet 142.150.250.0 255.255.255.128 101
exit
stack
member 1 2
exit
ip address 10.0.0.1 255.255.255.0
ip routing
ip route 0.0.0.0 0.0.0.0 142.150.250.1
interface vlan 100
routing 
ip address 10.10.20.254 255.255.0.0 exit interface vlan 101 routing ip address 142.150.250.6 255.255.255.128 exit
aaa authentication enable "enableList" enable
ip ssh server
!
interface ethernet 1/g13
description 'Public Access to Apes'
spanning-tree portfast
switchport access vlan 101
exit
! 
interface ethernet 1/g14 description 'Cluster Access to Apes' spanning-tree portfast switchport access vlan 100 exit
! interface ethernet 1/g15 description 'Pharmacy Public Access to Goonies' spanning-tree portfast switchport access vlan 101 exit
! interface ethernet 1/g16 description 'Pharmacy Cluster Access to Goonies' spanning-tree portfast switchport access vlan 100 exit ! interface ethernet 1/g17 description 'Pharmacy Cluster Access to Pulp' spanning-tree portfast switchport access vlan 100 exit ! interface ethernet 1/g18 description 'Pharmacy Public Access to Pulp'
spanning-tree portfast switchport access vlan 101 exit ! interface ethernet 1/g19 description 'Pharmacy Cluster Access to Django' spanning-tree portfast switchport access vlan 100 exit ! interface ethernet 1/g20 description 'Pharmacy Public Access to Django' spanning-tree portfast switchport access vlan 101 exit ! interface ethernet 1/g25 description 'Public Access to Backup' spanning-tree portfast switchport access vlan 101 exit
! interface ethernet 1/g26 description 'Cluster Access to Backup' spanning-tree portfast switchport access vlan 100 exit ! interface ethernet 1/g41 switchport access vlan 101 exit ! interface ethernet 1/g43 switchport access vlan 101 exit !
interface ethernet 1/g45 channel-group 2 mode auto description 'trunk to pharmacy rack 1' exit !
interface port-channel 1 spanning-tree portfast switchport mode general switchport general pvid 101 switchport general allowed vlan add 101 exit !
interface port-channel 2 description 'Trunk to pharmacy rack 1' spanning-tree portfast switchport mode trunk switchport trunk allowed vlan add 100-101 exit *** exit
SWITCH1:

console#show running-config !Current Configuration: !System Description "PowerConnect 6248, 3.3.1.10, VxWorks 6.5" !System Software Version 3.3.1.10 !Cut-through mode is configured as disabled ! configure vlan database vlan 100-101,200 vlan routing 101 1 vlan routing 100 2 vlan routing 200 3 vlan association subnet 10.10.0.0 255.255.0.0 100 vlan association subnet 10.20.0.0 255.255.0.0 200 vlan association subnet 142.150.250.0 255.255.255.128 101 exit stack member 1 2 exit ip address 10.0.0.1 255.255.255.0 ip name-server 128.100.100.129 ip name-server 128.100.96.24
ip routing ip route 0.0.0.0 0.0.0.0 142.150.250.1 interface vlan 100 name "Pharmacy Cluster Network" routing ip address 10.10.10.254 255.255.0.0 exit interface vlan 101 name "Public Pharmacy Network" routing ip address 142.150.250.5 255.255.255.128 exit interface vlan 200 routing exit
aaa authentication enable "enableList" enable
line console
exit
ip ssh server 
ip ssh pubkey-auth ! interface ethernet 1/g1 description 'Pharmacy public to fawlty' spanning-tree portfast switchport access vlan 101 exit ! interface ethernet 1/g2 description 'Pharmacy cluster to fawlty' spanning-tree portfast switchport access vlan 100 exit ! interface ethernet 1/g3 shutdown exit ! interface ethernet 1/g4 shutdown exit
! interface ethernet 1/g5 description 'Pharmacy public to towers' spanning-tree portfast switchport access vlan 101 exit ! interface ethernet 1/g6 description 'Pharmacy cluster to towers' spanning-tree portfast switchport access vlan 100 exit ! interface ethernet 1/g9 description 'Pharmacy public access to blues' spanning-tree portfast switchport access vlan 101 exit ! interface ethernet 1/g10 description 'Pharmacy Cluster access to blues'
spanning-tree portfast switchport access vlan 100 exit ! interface ethernet 1/g11 description 'Pharmacy Public to ET' spanning-tree portfast switchport access vlan 101 exit ! interface ethernet 1/g12 description 'Pharmacy Cluster to ET' spanning-tree portfast switchport access vlan 100 exit !
interface ethernet 1/g25 description 'Pharmacy Cluster to CMCIII' spanning-tree portfast switchport access vlan 100 exit ! interface ethernet 1/g26 shutdown exit ! interface ethernet 1/g27 shutdown exit ! interface ethernet 1/g28 shutdown exit ! interface ethernet 1/g29 shutdown exit
! interface ethernet 1/g30 shutdown exit ! interface ethernet 1/g31 channel-group 2 mode auto description 'trunk to pharmacy rack 2' spanning-tree portfast exit ! interface ethernet 1/g32 shutdown exit !
interface ethernet 1/g34 shutdown
exit ! interface ethernet 1/g35 shutdown exit ! interface ethernet 1/g36 channel-group 3 mode on description 'trunk to pharmacy rack 3' spanning-tree portfast exit ! interface ethernet 1/g43 channel-group 1 mode on spanning-tree portfast exit ! interface ethernet 1/g44 channel-group 1 mode on shutdown exit ! interface ethernet 1/g47 shutdown exit ! interface port-channel 1 description 'External Access to University Network' spanning-tree portfast switchport mode general switchport general pvid 101 switchport general allowed vlan add 101 exit ! interface port-channel 2 description 'Trunk to pharmacy rack 2' spanning-tree portfast switchport mode trunk switchport trunk allowed vlan add 100-101,200 exit ! interface port-channel 3 description 'Trunk to pharmacy rack 3' spanning-tree portfast switchport access vlan 100 exit snmp-server community public ro
exit